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Premessa 
Gli Starter Kit per Multisim 11 e Ultiboard 11 sono concepiti come supporto ai cosi Elettrotecnica ed 
Elettronica e Telecomunicazioni, edizione 2012, della casa Editrice Tramontana. Come tali, non affrontano 
tutti gli aspetti legati a questi software ma si limitano a fornire un aiuto a comprendere al meglio le modalità 
operative delle molte simulazioni e i molti progetti di PCB proposti nel suddetto corso.  
I volumi del corso che potranno trovare pieno supporto da questi scritti sono: 
 
Elettrotecnica ed Elettronica vol. 1 + DVD edizione 2012         
ISBN 978-88-2333513-4 
 
Elettrotecnica ed Elettronica vol. 2 edizione 2012 
ISBN 978-88-2333612-4 
 
Elettrotecnica ed Elettronica fascicolo per articolazione Elettronica edizione 2012   
ISBN 978-88-2333686-5 
 
Elettrotecnica ed Elettronica fascicolo per articolazione Elettrotecnica edizione 2012  
ISBN 978-88-2333685-8 
 
Elettrotecnica ed Elettronica vol. 3 per articolazione Elettronica edizione 2013   
ISBN 978-88-2333522-6 
 
Elettrotecnica ed Elettronica vol. 3 per articolazione Elettrotecnica edizione 2013   
ISBN 978-88-2333521-9 
 
Elettrotecnica ed Elettronica vol. 3 per articolazione Automazione edizione 2013   
ISBN 978-88-2333526-4 
 
Telecomunicazioni vol. unico + DVD edizione 2012 
ISBN 978-88-2333422-9 
 
Telecomunicazioni vol. 1 + DVD edizione 2012       
ISBN 978-88-2333436-6 
  
Telecomunicazioni vol. 2 edizione 2012        
ISBN 978-88-2333417-5  
 
Telecomunicazioni vol. 3 edizione 2013        
ISBN 978-88-2333430-4 
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1. Introduzione 
 
Ultiboard è l’applicazione PCB1 (Printed Circuit Board) della National Instruments che assiste nella 
progettazione di circuiti stampati, per prepararli per la produzione. Prevede la rappresentazione grafica 
planimetrica (layout) di circuiti stampati e l’inserimento automatico di vari componenti elettronici, già presenti 
nel proprio archivio, oltre alla possibilità di crearne di nuovi. 
Ultiboard rappresenta una piattaforma di progettazione facile e intuitiva oltre ad offrire funzionalità 
automatiche per velocizzare lo sviluppo di PCB e tecniche manuali per controlli di precisione. Questa 
flessibilità, unita all’integrazione con Multisim, consente di ottimizzare e facilitare il processo di progettazione 
del circuito stampato partendo dallo schematico, creato con Multisim, fino alla produzione: Ultiboard 
permette di completare il processo di layout, dal posizionamento dei componenti alla stesura delle piste, con 
funzioni di autorouting avanzato integrato e posizionamento delle tracce che assicurano un preciso controllo 
del disegno durante la fase di realizzazione di un prototipo. 
 

 
Figura 1 – Ultiboard. 

In figura 1 è visualizzata una schermata di Ultiboard: il foglio di lavoro sul quale viene realizzato il PCB del 
circuito elettronico è affiancato da vari menu e barre degli strumenti che consentono l'accesso ai comandi 
di Ultiboard, e permettono l’inserimento di utili viste.  
La barra in alto o barra dei menu ci permette di accedere a tutte le funzioni che il software offre. I primi due 
menu da sinistra, File e Edit (presenti in vari applicativi Windows), contengono pulsanti noti ai più, ai quali 
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1 Un circuito stampato si compone di un supporto di materiale isolante (la basetta), piano e di spessore costante su cui viene applicata 
una lamina di rame, anch’essa uniforme e di spessore costante. Quello che si fa, al momento della realizzazione di un PCB, è di 
eliminare tutto il rame che non occorre, lasciando solo quello necessario ai collegamenti elettrici (piste elettriche e piazzole).  
L’asportazione chimica selettiva del rame in eccesso sulla basetta, avviene tramite preliminare processo fotografico (eseguito con un 
bromografo) per impressionarla con il disegno del circuito stampato, e successiva immersione in liquido di sviluppo, responsabile 
dell’asportazione del rame indesiderato. In alternativa è possibile impiegare la tecnica di fresatura del PCB (che evita l’uso di acido e 
fotoresist) attuata asportando dalla basetta il rame non utile mediante sfregamento con una opportuna punta di trapano.  
In ogni caso, ottenuta la piastra contenente le piste elettriche, si passa alla foratura all’interno delle piazzole per consentire il passaggio 
dei terminali dei componenti elettronici, i quali vengono poi fissati con saldatura a stagno. 
 



però si aggiungono comandi specifici di Ultiboard che affronteremo nella nostra trattazione. File riguarda la 
gestione dei file (New Design, Open, Save, Close e altri pulsanti), mentre Edit è inerente alla gestione del 
documento (Undo, Redo, Cut, Copy, Paste e altri pulsanti). 
 

 In Ultiboard, per il primo salvataggio, è possibile salvare un singolo disegno su cui si sta lavorando o un 
intero progetto (composto da più disegni e documenti) usando lo stesso comando File > Save As. 
Successivamente per salvare un disegno usare semplicemente File > Save (anche all’interno di un progetto) 
oppure File > Save all per salvare tutti i documenti aperti in un certo momento. 
 

 Il menu File > Open permette l’apertura di documenti salvati in vari formati, tra i quali: Ultiboard files 
(*.ewprj), Orcad files (*.max, *.llb), DXF files (*.dxf), Gerber file (*.grb), netlist file (*.ewnet).  
Inoltre, mediante l’opzione File > Open Samples è possibile aprire dei progetti di esempio per prendere 
dimestichezza con Ultiboard.  
 
Il menu View permette di includere delle utili viste, tra cui: 
• Design Toolbox nella modalità Project elenca tutti gli oggetti che fanno parte di un progetto, mentre 

nella modalità Layers consente di mostrare, oscurare o nascondere elementi della progettazione, o con 
doppio click del mouse permette di evidenziare lo strato (layer) su cui lavorare; 

 
• Birds Eye mostra il circuito stampato in un colpo d'occhio e permette di raggiungere facilmente i punti di 

lavoro scelti: per selezionarli tracciate un’area sulla parte da ingrandire, usando il mouse mentre tenete 
premuto il pulsante sinistro;  

 
• 3D preview mostra l’anteprima tridimensionale del circuito; 
 
• Spreadsheet View è un foglio di lavoro con varie sezioni: 

o Parts permette una agevole visualizzazione e la modifica dei parametri dei componenti utilizzati, 
compresi alcuni dettagli, come la relativa impronta (footprint) con indicata la piedinatura, il codice di 
designazione, gli attributi e i vincoli di progettazione; 

o DRC segnala errori di disegno (i quali vengono indicati con un cerchio rosso sul foglio di 
progettazione) ed è possibile raggiungerli mediante un doppio clic sulla relativa descrizione, 
ottenendo un ingrandimento della zona interessata del circuito. 

o Nets per lavorare con la netlist circuitale, che permette di modificare vari attributi relativi ai nodi, 
indicandone anche lo sviluppo della relativa traccia lungo il PCB. 

 

 Density bars sono due strisce colorate, poste sulla destra e sotto l’area di lavoro, che raffigurano la 
densità dei componenti sul master (andando da un valore minimo indicato con colore verde, ad massimo 
con colore rosso). Si attivano e disattivano seguendo il percorso View > Density bars. 
 

 L’opzione View > Grid permette di inserire o di togliere la griglia sul foglio del PCB. 
 

  L’opzione View > Status Bar abilita la barra di stato in basso, che visualizza importanti informazioni 
sul lavoro in corso. 
 

Vedremo gli altri menu che il software offre e le funzioni che è possibile attivare, man mano che 
svilupperemo lo sbroglio di un circuito stampato. 
 

 
2. Creazione di un circuito stampato in ambiente Ultiboard 
 
2.1 Definire un nuovo progetto in Ultiboard  
 

Si vuole realizzare il circuito stampato di un alimentatore a tensione fissa (figura 2a), utilizzando un 
regolatore di tensione LM7805, per alimentare un circuito elettronico con tensione fissa VO = +5V, sfruttando 
una maggiore tensione in ingresso. 
 

 Per realizzare un nuovo circuito stampato in Ultiboard bisogna aprire un nuovo progetto, che raggruppa 
in un unico file disegni e modelli che hanno un collegamento logico tra di loro, per un facile accesso.  
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Scegliendo File > New Project appare la finestra di dialogo New Project (figura 2b). Nella casella Project 
name inserite il nome del progetto. Come Design type selezionate PCB Design, mentre l'altra opzione 
possibile è Mechanical CAD, che consente di utilizzare Ultiboard come CAD meccanico, per progettare 
pannelli frontali, case per i circuiti integrati, ecc. Nella casella Location indicate la cartella di lavoro dove 
verrà salvato il progetto.  
Cliccando su OK, la finestra di dialogo scompare e viene aperto uno spazio vuoto di progettazione con lo 
stesso nome del file di progetto. Il file appena creato è anche indicato nella scheda Project della Design 
Toolbox, insieme con eventuali altri disegni e modelli che verranno aggiunti durante la progettazione. Per 
dare un nuovo nome a un disegno o a un modello, fare clic su di esso con il pulsante destro del mouse e 
scegliere Rename, oppure nel caso lo si voglia eliminare dal progetto scegliere Remove design. 
 

 
 
 
 
 
 
 

 
 

 
 
 
 

a) 
  

b) 
Figura 2 –Alimentatore con regolatore 78XX a tensione in uscita fissa (a), nuovo progetto (b). 
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 Per definire forma e misure del circuito stampato si utilizza la procedura guidata Tools > Board Wizard. 
Nella finestra che si apre è possibile cambiare la tecnologia a strati (layers) del circuito stampato, spuntando 
Change the layer technology2. Per scopi didattici è preferibile usare una Technology di tipo Double-
sided, ma è possibile lasciare spuntata la voce di default Multi-layers constructed with double-sided 
boards (layer pairs), selezionando direttamente Next e nella schermata successiva scegliendo le 
impostazioni di laminazione con il numero di coppie di strati su cui si svilupperà il PCB. In tal caso alla voce 
Lamination settings sceglieremo comunque Layer pairs pari a 1, per cui sarà possibile usare le comuni 
basette a singola (single sided) o a doppia faccia (double sided). 
Si passa quindi a definire la forma e le dimensioni della basetta. Nel campo Units (figura 3) viene richiesto di 
impostare l’unità di misura per la progettazione, che di default è il mil3, ma può essere conveniente 
cambiarla in mm. Per il Reference point (punto di riferimento) è comodo selezionare la posizione in basso a 
sinistra della basetta, inserendo alla voce Alignement l’opzione Bottom-left, anche se questa scelta può 
essere modificata successivamente.   
Seguono le impostazioni Board Shape and Size sulla forma e le dimensioni della basetta, che è comodo 
lasciare nel formato rettangolare 160x100 mm e modificare successivamente, in caso il PCB dovesse 
richiedere una superficie maggiore o minore di quella preventivata.  
In ultimo, è possibile impostare anche la Clearance della basetta, ossia la distanza dal bordo della scheda 
che deve essere mantenuta libera da altri elementi circuitali. Fare clic sul pulsante Finish per concludere e 
visualizzare la bozza della basetta pronta per la progettazione. 
 

                                                      
 
2 A seconda degli strati conduttivi presenti nel circuito stampato si parla di singola faccia (i circuiti sono stampati solo su di un lato della 
basetta), doppia faccia (i circuiti sono stampati su di entrambi i lati della basetta), multistrato (basette con tre o più strati conduttivi 
assemblati l’uno sull’altro). Ultiboard permette di realizzare anche basette multistrato fino a 64 strati di profondità. 
3 Il mil è un'unità di misura di lunghezza che non fa parte del sistema SI, ma che è tuttora ampiamente utilizzata nei paesi di cultura 
anglosassone, oltre che in molti settori tecnologici. È il millesimo di pollice (inch): 1 mil = 0,001 in = 25,4 μm = 0,0254 mm. 
 

VO 

           1                         3 
         IN                         OUT 
+ 
 
 
 
 

                                          100μF                                                                     2  GND    100nF 

VI 

 
LM78XX 



Figura 3 – Board Wizard, opzioni di definizione di forma e misura della basetta. 
 
 
2.2 Utilizzare i componenti del database 
 

 È arrivato il momento di cominciare a disegnare il circuito stampato, procedendo con l’immissione dei 
componenti dall’archivio di Ultiboard, scegliendo Place > From Database che apre la finestra Get a Part 
from the Database. Nella colonna Database, espandere il percorso Ultiboard Master > Through Hole 
Technology Parts, all’interno del quale troverete tutti i componenti del circuito elettronico proposto in figura 
2a. Il regolatore LM7805 si trova nella sezione Voltage Regulators scegliendo 78XXV tra le Available 
parts (figura 4).  
Il footprint del dispositivo scelto appare nel Preview, all’interno del quale mediante il pulsante Show 
Dimension è possibile visualizzare le dimensioni delle varie parti che lo compongono, nell’unità di misura 
scelta tra quelle presenti nell’elenco a discesa Units, oltre a poter modificare la visualizzazione, agendo sui 
pulsati di zoom. Facendo clic su OK, appare la finestra di dialogo Enter Reference Designation for Part, 
all’interno della quale, nel campo REFDES (Reference Designator) va inserito il codice di designazione 
scelto per il dispositivo, mentre nel campo Value va inserita una indicazione sul valore del dispositivo (per 
esempio, 20k per un resistore). Immettete REFDES = U1, Value = LM7805 e date l’OK per posizionare il 
dispositivo sul piano di progetto. 
Successivamente andranno inseriti gli altri componenti: il condensatore elettrolitico (Ultiboard Master > 
Through Hole Technology Parts > Capacitors > Radial > CAPPR1000-2200X2500), l’altro condensatore 
(Ultiboard Master > Through Hole Technology Parts > Capacitors > Ceramic/Plastic > KERKO4X3R5), 
i pin di ingresso e di uscita (Ultiboard Master > Through Hole Technology Parts > Connectors > 
Headers > HDR1x2) che nominerete, nel campo REFDEF, come Vin e +5V. 
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Figura 4 – La finestra Get a Part from the Database. 
 
 
2.3 Le opzioni di selezione  
 
È importante adesso soffermarsi sulle opzioni di selezione. È possibile selezionare e deselezionare singoli o 
multipli elementi in un disegno (componenti, piazzole, piste, ecc.) per poterli spostare, o per modificarne le 
proprietà: 
• per selezionare un singolo elemento è necessario cliccare su di esso con il pulsante sinistro del mouse e 

questo verrà evidenziato con una linea tratteggiata intorno; 
• è anche possibile selezionare più elementi su un’area, tenendo premuto il tasto sinistro del mouse e 

includendoli nell’area tratteggiata rettangolare visibile durante il trascinamento del puntatore;  
• per selezionare/deselezionare singolarmente più elementi è necessario tenere premuto il tasto CTRL 

mentre si clicca su ciascuna selezione con il pulsante sinistro del mouse; 
• per selezionare tutti gli elementi di un disegno, premere CTRL+A; 
• per agire sulle proprietà di uno o più elementi selezionati, basta fare doppio clic sulla selezione con il 

pulsante sinistro del mouse (che ne aprirà direttamente la casella delle proprietà), o fare un solo clic con 
il pulsante destro (in tal caso verrà visualizzato il relativo menù contestuale, con le voci delle azioni che è 
possibile compiere, tra cui anche l’opzione di avere accesso alle proprietà della selezione).  

 
Per effettuare correttamente una selezione è comunque necessario sapere usare i filtri di selezione che 
consentono di distinguere i vari elementi di disegno, permettendo un controllo dettagliato delle scelte. La 
selezione dei filtri è raggiungibile mediante Edit > Selection Filter o sulla barra degli strumenti attraverso il  
menu Select. È possibile scegliere una o più tipologie di elementi, abilitandoli con il rispettivo pulsante: 
 

 Enable Selecting Parts permette di selezionare i componenti circuitali;  
 

 Enable Selecting Traces permette di selezionare le piste (traces);   
 

 Enable Selecting Polygons permette di selezionare poligoni di rame tracciati sul PCB; 
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 Enable Selecting Vias permette di selezionare le vie di comunicazione (vias) tra i vari layer di un 
circuito stampato multistrato; 
 

 Enable Selecting Pads permette di selezionare le piazzole (pads); 
 

 Enable Selecting SMD Pads permette di selezionare le piazzole per i dispositivi a montaggio 
superficiale (Surface Mount Device); 
 

 Enable Selecting Attributes permette di selezionare gli attributi testuali dei vari oggetti;  
 

 Enable Selecting other objects permette di selezionare altri oggetti sul PCB (ad esempio i ponticelli 
esterni o il contorno della basetta).   
 
 
2.4 Usare la Netlist 
 
Dopo avere scelto i componenti dal database è necessario inserirli nella netlist utilizzando l’editor 
raggiungibile mediante Tool > Netlist Editor, che permette di aggiungere o rimuovere una rete (Net) nella 
progettazione, aggiungere o eliminare piazzole (Pins) e collegamenti in una rete esistente, regolare la 
professionallarghezza delle tracce (Width), impostare i parametri di alta velocità (High Speed, presente solo 
sulle versioni professionali di Ultiboard), raggruppare le reti (Groups) e settare le caratteristiche delle vie di 
comunicazione (Vias) tra i vari layer. 
 

Figura 5 – Netlist Editor. 
 
Per aggiungere una nuova rete, all’interno del Netlist Editor, fare clic sulla scheda Pins (figura 5) e quindi sul 
pulsante New all’interno del riquadro Net, che aprirà la finestra di dialogo Add Net, all’interno della quale 
comincerete con l’inserire il nodo di massa, che chiamerete 0, quindi date OK. Il nuovo nome verrà 
visualizzato nell’elenco di rete.  

 La luce verde luminosa accanto al nodo indica che non ci sono piazzole collegate alla rete 0 e 
per aggiungerle è necessario aiutarsi con il puntatore del mouse, dopo avere abilitato il pulsante di 
puntamento all’interno della sezione Pins, oppure usando il pannello testuale Add Pins to the Net che 
riporta tutti i pin del circuito, aprendolo mediante il pulsante Add.    
Seguendo il circuito di figura 2a, selezionate tutte le piazzole che vanno collegate a massa, le quali si 
coloreranno di blu più luminoso e verranno via via elencate nella sezione Pins (ad esempio “Vin, Pin 2” 
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indica che si è collegata la piazzola 2 del componente nominato Vin). Nel circuito che si sta realizzando, alla 
rete 0 verranno collegate le seguenti piazzole: Vin, Pin 2 – U1, Pin 2 – +5V, Pin 2 – C2, Pin 2 – C1, Pin 2. 
Aggiungete adesso la rete 1, usando sempre il pulsante New (all’interno del riquadro Net) e mediante essa 
collegate le piazzole  Vin, Pin 1 – U1, Pin 1 – C1, Pin 1. In ultimo aggiungete la rete 3 che collega le piazzole 
+5V, Pin 1 – U1, Pin 3 – C2, Pin 1. Date l’OK e alla chiusura della finestra Net Edit, vedrete che sul disegno 
appariranno delle linee di raccordo che indicano i collegamenti tra le varie piazzole inseriti nella netlist. 
Aprendo successivamente la finestra Net Edit, vi accorgerete che la luce verde accanto alle reti indicate 
nel menu a discesa rimane luminosa solo per quelle reti che sono rimaste non collegate, mentre passa a 
verde opaco per quelle reti che sono state utilizzate per collegare almeno due piazzole.  
 
Allo stesso modo, volendo inserire un nuovo componente dal database, è possibile collegare le relative 
piazzole alle reti già presenti nella Netlist. Operando all’interno della finestra Net Edit si sceglie di volta in 
volta (dall’elenco a discesa all’interno del riquadro Net) la rete a cui collegare una o più piazzole del nuovo 
componente e poi si associano le piazzole usando il sistema di selezione della sezione Pins, come appena 
descritto. È buona regola usare la Netlist per tenere aggiornati i collegamenti tra i vari componenti del PCB, 
ciò tornerà utile al momento del tracciamento delle piste.  
 
È importante considerare altre utili sezioni presenti nella finestra Net Edit. Nella sezione Width è possibile 
settare l’ampiezza delle piste da tracciare su PCB, nei campi Minimum trace width, Default trace width e 
Maximum trace width, esprimendole nell’unità di misura prescelta. Come raffigurato in figura 6a, è comodo 
scegliere Minimum trace width = 10 mil, Default trace width = 20 mil e lasciando Maximum trace width al 
valore di default settato dal software. 
 
Da considerare anche la Clearance, ossia la distanza minima che va tenuta libera attorno alle piazzole, alle 
tracce e a qualsiasi altro elemento in rame segnato su PCB, come pure dal bordo della basetta stessa. Il 
tentativo di eseguire una traccia o di mettere un componente in modo tale che una delle sue piazzole finisca 
all’interno della distanza minima consentita è segnalato con un errore, cerchiato di rosso e segnalato nella 
relativa sezione DRC dello Spreadsheet View. 
Viene settata una Clearance = 10 mil. 
 

 
a) 

 
b) 

Figura 6 – Netlist Editor: Width (a), Misc (b).  
 
Si analizza la sezione Misc della Net Edit (figura 6b): nell’area Routing Layers è possibile indicare, per 
ciascuna rete (net), uno o più strati dove si potrà sviluppare. Ciò in funzione del successivo inserimento delle 
piste sia in modalità automatica (sfruttando gli algoritmi di routing di Ultiboard) che in modalità manuale. 
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Nel caso del circuito in realizzazione, le reti 0, 1 e 2 si trovano al livello superficiale (dato che si vuole 
realizzare un circuito stampato su singola faccia), quindi si lascia la spunta solo su Copper Top. Questo 
costringerà l’algoritmo di routing di Ultiboard a trovare collegamenti per le reti 0, 1 e 2 che interessino solo lo 
strato superficiale del PCB. Allo stesso modo, se si procedesse allo sbroglio in modalità manuale, non 
sarebbe possibile realizzare una certa pista tra tali piazzole, facendola scorrere su un layer diverso dal 
Copper Top, perché verrebbe visualizzato un errore nella sezione DRC della Spreadsheet View. 
In ogni caso per circuiti singola faccia è indifferente eseguire lo sbroglio lato rame o lato componenti, pur di 
sistemare bene le cose all’atto di inviare il master ad una fresa, mentre se si sceglie di riprodurre il master su 
basette presensibilizzate, prima di stampare su carta lucida va considerata l’opzione di stampa Print 
Reflection (si rimanda alla sezione 3 di questo starter kit). 
Nel caso invece si voglia realizzare un circuito stampato doppia faccia è conveniente settare per ciascuna 
rete, ambedue i layers: Copper Top e Copper Bottom (lasciando all’algoritmo di routing di Ultiboard un 
grado di libertà sulla scelta di posizionamento della pista), oppure è possibile forzare per ogni rete una tra le 
due facce, secondo le proprie necessità progettuali. 
 
 
2.5 Realizzare il disegno del PCB in modalità manuale o automatica 
 
È conveniente, prima di tutto, dimensionare adeguatamente le piazzole dei vari componenti. Abilitate il 
pulsante Enable Selecting Pads e selezionate tutte le piazzole che volete modificare, quindi cliccate con il 
pulsante destro del mouse su una selezione e nel menu contestuale che si apre scegliete Properties. Si 
aprirà la finestra Through Hole Pin Properties (figura 7) nella cui sezione Pad è possibile agire sulle 
caratteristiche delle piazzole. Per il PCB in corso modificherete solo la Shape (forma) del Copper Top (rame 
superficiale), dato che si vuole realizzare un master su singola faccia, scegliendola di tipo Round, con Pad 
Diameter (diametro della piazzola) di 1,9 mm e Hole (foro) di tipo Standard con Drill Diameter (diametro 
della punta del trapano) di circa 1 mm (le stesse misure tradotte in mil saranno: Pad Diameter di circa 75 mil 
e Drill Diameter di circa 40 mil). Dopo aver dato l’Apply, passate alla sezione Layer settings per rimuovere 
la spunta dalla voce Copper Ring inerente il checkbox Copper Bottom; lasciate la spunta solo sull’opzione 
Copper Top, il che equivale ad indicare al software che si vuole realizzare un master su singola faccia, e poi 
date OK. Questa scelta non modifica la netlist ma vale solo per l’autorouting. In alternativa  è possibile 
effettuare la stessa scelta nella scheda Copper layers dello Spreadsheet View.  
 

Figura 7 – Through Hole Pin Properties. 
 
È arrivato il momento di inserire le piste, che può essere fatto utilizzando uno dei metodi spiegato di seguito, 
in modalità manuale oppure automatica. 
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 Il metodo Manual Trace consente il massimo controllo nel collocamento delle tracce tra piazzole e vias 
e si abilita scegliendo Place > Line. Dopo avere selezionato una piazzola, muovendosi con il mouse, si 
traccia il percorso fino a raggiungere la successiva piazzola da collegare o fino a una traccia già esistente. 
Torna utile l’avere inserito in precedenza nella netlist i collegamenti tra le reti, perché durante il tracciamento 
il software evidenzia sia i percorsi da coprire con le piste (mediante una linea luminosa), sia le piazzole da 
raggiungere nel PCB (mediante una X).  
Agendo sulla barra Draw Settings, come si vede in figura 8, è possibile scegliere il valore desiderato per lo 
spessore (width) delle piste, in luogo di quello automatico. Nel caso del PCB proposto si è scelto 20 mil. Allo 
stesso modo, durante la tracciatura di una pista, è possibile variare il suo spessore, cliccando con il pulsate 
destro del mouse in un punto qualsiasi e scegliendo (nel relativo menu contestuale) se aumentarlo: Widen 
(CTRL+Maiusc+W), oppure se ridurlo: Narrow (CTRL+Maiusc+N). La stessa barra permette di selezionare 
lo strato su cui tracciare una pista (in figura 8 si sta usando il copper top). 
Questo metodo supporta un tracciamento continuo delle piste: la successiva pista comincia dall'ultima 
piazzola collegata. Per interrompere il tracciamento, uscire cliccando con il tasto destro del mouse e 
scegliendo Cancel, oppure premendo ESC da tastiera: l’ultimo tratto di pista verrà rimossa dal PCB. 
 

 
Figura 8 – Tracciamento piste in modalità Manual Trace e barra Draw Settings. 
 

 Follow Me Router è il metodo che consente di tracciare le piste selezionando una prima piazzola o una 
via e poi le successive piazzole da collegare a questa e lasciando ad Ultiboard il compito di seguire il vostro 
movimento del mouse e di trovare il percorso migliore tra i vari ostacoli. Si abilita selezionando Place > 
Follow-me.  
Questo metodo supporta un tracciamento continuo delle piste: la successiva pista comincia dall'ultima 
piazzola collegata.  
Anche in questa modalità, durante la tracciatura di una pista, è possibile variare il suo spessore, cliccando 
con il destro in un punto qualsiasi e scegliendo se aumentarlo, Widen (CTRL+Maiusc+W), oppure se ridurlo, 
Narrow (CTRL+Maiusc+N). Dopo aver tracciato un gruppo di piste, per concludere e passare ad un'altra 
parte del circuito, è necessario cliccare con il pulsante destro del mouse: rimarranno sul piano di lavoro solo 
le piste fin qui disegnate, l’ultimo tratto di pista verrà rimossa dal PCB.  
  

 Connection Machine (solo per le versioni professionali di Ultiboard) è il metodo che collega due 
piazzole o vias con una traccia che viene automaticamente reindirizzata nei pressi di eventuali ostacoli. Si 
procede cliccando direttamente su ciascuna delle linee di raccordo che indicano i collegamenti tra le varie 
piazzole e vias (ottenute dall’inserimento in netlist delle varie reti che compongono il circuito). 
Questo metodo non supporta un tracciamento continuo delle tracce, come avviene per gli altri metodi, ma 
disegna una pista alla volta. Si abilita scegliendo Place > Connection Machine. 
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 Ricordate che per uscire da ciascuna delle precedenti modalità di tracciamento (Manual Trace, Follow 
Me Router, Connection Machine) e tornare alla modalità di puntamento del mouse è necessario abilitare 
l’icona Place > Select.  
Per cancellare un’intera pista o parti di essa, è necessario effettuare una selezione con il mouse, dopo avere 
abilitato Edit  > Selection Filter > Enable Selecting Traces, quindi procedere alla cancellazione facendo 
uso dell’opzione Delete contenuta nel relativo menù contestuale, oppure mediante il tasto CANC. 
Per spostare da un layer ad un altro una pista appena tracciata è necessario tornare alla modalità di 
puntamento del mouse, selezionando la pista in oggetto, dopo avere abilitato Enable Selecting Traces 
(oppure usando il menu Edit > Selection Filter > Enable Selecting Traces), fare doppio clic su di essa con 
il pulsante sinistro del mouse e nella successiva finestra di dialogo Trace Properties, nella sezione 
Position, scegliere il layer voluto. Ultiboard inserirà in automatico la via per passare da un layer all’altro. 
 

 Scegliendo View > Clearances è possibile visualizzare lo spazio che va tenuto libero (clearance) 
intorno ad ogni elemento circuitale, il cui limite è rappresentato da sottili linee blu che circondano tracce, 
piazzole e vias. 
 
In alternativa all’inserimento delle tracce in modalità manuale è possibile sfruttare gli automatismi offerti dal 
software: l’autorouting e l’autoplacement (presente solo su alcune versioni di Ultiboard 11). Le opzioni 
generali di routing, vanno impostate nella finestra Routing Options, raggiungibile mediante Autoroute > 
Place Option. Lasciate, al momento, tutto come impostato di default e procedete ad usare l’automatismo di 
tracciamento delle piste così come si presenta. 
 

 L’autorouting viene attivato dal pulsante Autoroute > Start/Resume Autorouter e offre la possibilità di 
collegare in maniera automatica le piazzole mediante piste, sfruttando l’algoritmo di routing di Ultiboard. Il 
software inizia a organizzare le piste sul PCB e visualizza il suo progresso nella barra di stato. Quando il 
processo è completo i risultati vengono visualizzati nella scheda Results dello Spreadsheet View.  
 

 Il pulsante Autoroute > Stop/Pause Autorouter permette di fermare l’algoritmo di autorouting, utile nel 
caso in cui, questo sia entrato in un ciclo, senza che riesca a portare a termine il tracciamento di tutte le 
piste del circuito. Ciò è ovviamente imputabile alla complessità circuitale, al modo in cui sono stati disposti i 
componenti sul PCB, alla limitazione di usare uno, piuttosto che più layer.  
Per aiutare il software nello sbroglio automatico, può essere conveniente, ad esempio, spostare i 
componenti sul foglio di lavoro, in modo tale da portare a termine anche i collegamenti mancanti tra le reti, 
oppure si può optare per aumentare il numero di layer, ad esempio passando da un circuito singola faccia a 
uno a doppia faccia, oppure si può provare con disposizioni alternative dei componenti (ad esempio, nel 
database di Ultiboard, in merito ai condensatori elettrolitici è possibile scegliere tra un dispositivo con 
collocazione in verticale o uno con disposizione in orizzontale lungo il piano, in modo che sotto possano 
passare più piste). Dopodiché riattivare l’Autorouter.  
È possibile avere informazioni sul processo di autoroute appena stoppato nella scheda Results dello 
Spreadsheet View, dove viene indicato anche il numero di connessioni sul totale portate a termine 
dall’autorouter. 
 
Nelle versioni professionali di Ultiboard è anche possibile eseguire il comando di autoroute solo su alcuni 
componenti selezionati, mediante Autoroute > Autoroute Selected Parts. 
 

 L’autoplacement (presente solo sulle versioni professionali di Ultiboard) è un utile tool che lascia al 
software  una organizzazione ottimale dei componenti sul PCB, in modo da agevolare l’algoritmo di 
autorouting per il tracciamento delle piste. Per eseguire l'autoplacer, selezionare Autoroute > Start 
Autoplacement. È anche possibile eseguire il comando solo su alcuni componenti selezionati, mediante 
Autoroute > Start Autoplace Selected Parts. 
Per visualizzare i risultati di un autoplacement, selezionare la scheda Results dello Spreadsheet View. 
 

  Il tool optimization (presente solo sulle versioni professionali di Ultiboard), attivabile da Autoroute > 
Start Optimization, è un ottimizzatore di piste e vias. Di solito è applicato dopo che l’autorouter abbia 
raggiunto il 100% di completamento. Elimina inutili vias, smussa e omogeneizza le piste per ridurre i costi di 
fabbricazione, completa anche residue connessioni rimaste aperte.  
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 In alcuni casi può essere necessario inserire un ponticello in luogo di una pista impossibile da tracciare 
sul PCB a meno di non dovere usare un ulteriore layer. Per fare ciò, assicurarsi di avere selezionato uno 
strato di rame (ad esempio di stare lavorando sul Copper Top). Scegliere Place > Jumper e cliccare sulla 
prima piazzola da collegare con il ponticello. Spostare il puntatore sul disegno per trasportare l’asse del 
ponticello verso la seconda piazzola. Se non si riesce a raggiungerla, fare clic in un punto qualunque (non 
occupato da elementi circuitali) per confermare il primo tratto, selezionare il punto di arrivo e tirare un altro 
tratto di ponticello verso la piazzola voluta, modificandolo in lunghezza e direzione, e così via fino alla fine. 
Per concludere con l’inserimento di un ponticello o per annullare un inserimento, cliccate con il tasto destro. 
È possibile anche inserire dei ponticelli in successione, proseguendo con il successivo a partire dalla 
piazzola finale del precedente.  
Per modificare le proprietà di un ponticello, dopo avere abilitato Edit  > Selection Filter > Enable Selecting 
other objects (o usando la relativa icona di comando), selezionarlo mediante doppio clic oppure mediante il 
pulsante destro del mouse, scegliendo Properties nel menù contestuale. Si aprirà la finestra di dialogo 
Jumper Properties dove sarà possibile intervenire su vari suoi attributi. 
 

 A conclusione dello sbroglio automatico, prima di passare alla produzione del PCB (ma anche prima di 
salvare, stampare o esportare un disegno), oppure durante lo sbroglio manuale, è importante fare uso del 
comando Design > DRC and Netlist Check che forza un controllo sull’integrità del lavoro svolto, eseguendo 
un check per scovare errori rispetto alle regole di disegno impostate (DRC: Design Rule Errors) o in merito 
alla netlist compilata. Gli errori vengono cerchiati in rosso sul foglio di progettazione ed elencati all’interno 
della sezione DRC dello Spreadsheet View (di cui si è accennato nella precedente puntata). 
In genere gli errori sono dovuti alla sovrapposizione di oggetti circuitali (piazzole, collegamenti tra layer, 
piste) e in ogni caso all’occupazione dello spazio da lasciare libero (clearance) tra gli oggetti, oppure ad 
errori di collegamento tra piazzole che non vanno collegate insieme. 
Durante l’autorouting invece il controllo degli errori viene eseguito e risolto in automatico, a meno del caso in 
cui il software non riesca a completare lo sbroglio, segnalando nella scheda Results dello Spreadsheet 
View la percentuale di lavoro portato a termine e il numero di reti rimaste non collegate e riportando in DRC 
tutti gli errori dovuti al non completamento dell’operazione, con la possibilità di raggiungerli cliccando due 
volte sulla relativa voce.  
 
Un altro importante comando, utile quando si lavora in modalità manuale e in ogni caso da provare almeno 
una volta prima di passare alla produzione del PCB, è Design > Connectivity Check che esegue un 
controllo sulle connessioni. Una volta selezionato, si apre la finestra di dialogo Select a Net, dove inserire la 
rete su cui eseguire il controllo di connessione, oppure di default un controllo generale su tutte le reti # All 
Nets #. Al solito, i risultati vengono visualizzati nella scheda Results dello Spreadsheet View, compreso gli 
errori che indicano i collegamenti dichiarati in netlist ma non realizzati nello sbroglio, con la possibilità di 
raggiungerli cliccando due volte sulla relativa voce.  
 
 
2.6 Stampare un circuito stampato o esportare un layout 
 

 Una volta disegnato il circuito stampato, si può passare alla realizzazione del PCB, stampandolo su 
carta lucida4 con una stampante, meglio se laser, in grado di garantire un’ottima risoluzione. Nella finestra di 
stampa (figura 9a) che si ottiene mediante File > Print, nell’area Layer settings è possibile selezionare i 
layer che si desidera stampare tra quelli disponibili nella lista Available layers, cliccando sulla freccia verso 
destra per muoverli all’interno della lista di stampa Layers to print o sull’altra per rimuoverli. 
La stampa su carta lucida del PCB dell’alimentatore con LM7805 va preparata selezionando il layer Copper 
Top, mettendo una spunta su Print reflection e su Leave drill holes open. In figura 9b è visualizzato il 
circuito stampato proposto. 
L’opzione Print header in stampa inserisce o meno l’intestazione della pagina che indica cosa si stia 
stampando: è consigliabile spuntarla sempre. 
Ultiboard permette una facile esportazione dei layout dei PCB negli standard industriali più diffusi sia per la 
produzione che per la prototipazione. 

                                                      
 
4 La stampa su carta lucida serve a mascherare la basetta ramata pre-sensibilizzata, da porre nel bromografo, dove mediante delle 
lampade UVA, viene impressionata, preparandola così all'immersione nel liquido di sviluppo per l’asportazione del rame indesiderato. 
Ciò che viene stampato in nero sul foglio lucido rimane, mentre il resto viene corroso. 
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È possibile importare o esportare i lavori in formato DXF (Drawing Exchange Format), sviluppato da 
Autodesk come soluzione per scambiare dati tra il programma AutoCAD e altri programmi e oggi utilizzato 
come formato di scambio tra vari software di CAD anche elettronico. 
Per importare un file DXF scegliere File > Import > DXF e seguire la procedura che appare a video. Invece 
per esportare il file in DXF, o in uno degli altri formati supportati da Ultiboard, bisogna scegliere File > 
Export e selezionarlo nella successiva finestra di dialogo che si apre (figura 9c).  
 

 a) 

 
b) 
 

 c) 
Figura 9 –Finestra di stampa (a), circuito stampato dell’alimentatore con LM7805 (b), finestra di 
esportazione (c). 
 
 
2.7 Preferenze generali del programma 
 

 
Figura 10 – Preferences: General Settings (a), Colors (b). 
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Il menu Option permette di impostare le preferenze generali del programma. Scegliendo Option > Global 
preferences si aprirà la finestra di dialogo Preferences. Per potere accedere a tutte le sezioni di 
impostazione è comunque necessario che si stia lavorando ad un progetto e che quindi sia aperto un file in 
Ultiboard. La finestra Preferences offre le seguenti schede:  
• General (figura 10a) regola le impostazioni generali del software, all’interno della quale potrebbe tornare 

utile abilitare l’Auto save ogni 5 minuti, impostare la preferenza di utilizzo della rotellina del mouse nella 
Mouse wheel behavior, e settare un valore per l’Undo buffer size (che determina il numero massimo 
di modifiche fatte che è possibile annullare in caso di errore) compatibilmente con le proprie esigenze di 
programmazione e la memoria del proprio PC: il valore di 100 è un buona scelta; 

• Paths consente sotto la voce General > Circuit default path di impostare il percorso di salvataggio dei 
documenti sul proprio PC, nella sezione User settings di assegnare e configurare il template desiderato 
per i propri file, mentre in Database Files di indicare gli archivi che contengono le impronte (footprints) 
dei vari componenti elettronici, rispettivamente Master, Corporate e User Database; 

• Colors (figura 10b) permette di scegliere i colori dei vari elementi presenti sul foglio di lavoro; 
• PCB Design include numerose opzioni di scelta, tra cui ne consideriamo alcune:  

o View > Show pin 1 mark permette di distinguere il piedino 1 di un dispositivo con un marchio unico; 
o View > Show pin info in pin consente di visualizzare il numero di pin e l’ampiezza della 

piazzola quando viene ingrandita;  
o Part drag > Re-route after move abilita il routing automatico delle piste collegate ad un 

componente dopo che è stato spostato con il mouse;  
o nell’area Action on DRC error va impostata l’azione da intraprendere quando Ultiboard incontra 

un errore nel disegno: è possibile settare Cancel the current action per l’annullamento 
automatico dell'evento che ha causato l’errore, oppure Ask for confirmation per chiedere 
conferma se annullarlo o completarlo, oppure Overrule per consentire che l’evento venga 
ugualmente completato (opzione consigliata);  

o nell’area DRC & Net check si può scegliere No Realtime Check per impedire il controllo degli 
errori di disegno in tempo reale già al collocamento degli oggetti sul piano di lavoro, oppure 
Check on action end per effettuare un controllo solo al termine di ogni azione (ad esempio 
l'inserimento o lo spostamento di un componente), oppure Full Realtime Check per il pieno 
controllo in tempo reale (opzione consigliata) degli errori;  

o nell’area Follow me router, settando l’opzione Continuous place, si abilita il software a porre 
in automatico l’inizio di una nuova pista nel punto finale di quella precedente, quando si lavora in 
modalità manuale di tipo Follow Me Router; in caso contrario sarà necessario fare clic con il 
mouse per iniziare una nuova traccia;  

• Dimensions permette di configurare le caratteristiche delle linee di quota: frecce, testo, distanza dagli 
oggetti quotati;  

• 3D Options permette di scegliere il Background color (colore di sfondo) del visualizzatore 3D e le 
Internal View Options nel caso si lavori su più layer.  

 
 

3. Creare un circuito stampato partendo da uno schematico  
di Multisim  
 
L’ambiente di progettazione di Ultiboard è ben integrato con il pacchetto di simulazione elettronica Multisim, 
consentendo di ottimizzare il processo di progettazione di un circuito stampato a partire dallo schematico 
fino alla produzione. Multisim comunque fornisce funzioni che possono essere integrate con molti altri 
programmi di layout PCB, usando l’opzione Transfer > Export to other PCB layout file e scegliendo il 
formato di esportazione voluto. 
In Multisim è possibile definire gli strati5 (layers) di PCB, e quindi impostare le reti (nets) ad essere instradate 
(routing) su tali strati, selezionando Option  > Sheet Properties e scegliendo la sezione PCB (figura 11a). 

 
 
5 In genere, per scopi non professionali si realizzano stampati a singola faccia in cui le piste vengono tracciate su una sola superficie, o 
a doppia faccia in cui, mentre i componenti vengono montati su un solo lato del circuito, le piste vengono disposte su entrambe le 
facce della basetta. 
Per usi professionali e produttivi vengono costruiti stampati multistrato (pcb multilayer), costituiti da più strati di piste che scorrono 
all'interno della basetta, oltre a quelle superficiali. Un circuito stampato multistrato è formato da un numero pari di layer,  tipicamente 4 o 
6, ma per applicazioni o necessità particolari si può andare oltre i 6 livelli. È un metodo più costoso e difficile da produrre rispetto alla 
singola o doppia faccia, ma è l'unica soluzione per ottenere circuiti stampati più compatti, permettendo si avvicinare al massimo i 
componenti elettronici.  



Qui, nel riquadro Copper layers è possibile scegliere quante sono le coppie di strati desiderati o Layer 
pairs, partendo dalla coppia principale di piste superficiali, rispettivamente Copper Bottom realizzate sul 
lato saldature e Copper Top sul lato componenti. Le successive coppie di strati che si vogliono aggiungere 
saranno tutte del tipo Copper Inner, o rame interno. Nel nostro caso è sufficiente abilitare una sola coppia di 
strati.  
 

Figura 11 –Gestione delle proprietà del PCB in Multisim (a), proprietà delle piste: Net Settings (b). 
 
Successivamente all’interno di Ultiboard sarà possibile settare ulteriori opzioni di progetto, indicare per le reti 
le specifiche desiderate, la minima e la massima ampiezza delle piste (tracks), la minima e la massima 
lunghezza delle piste, la distanza minima (clearance) tra le piste, le dimensioni e le caratteristiche di piazzole 
(pads) e collegamenti tra layer (vias). Comunque alcune di queste caratteristiche si possono già impostare in 
Multisim, ad esempio per quanto riguarda le piste, aprendo la relativa finestra di dialogo delle proprietà Net 
Settings (figura 11b), a cui si perviene cliccando due volte su ciascuna di esse nello schematico (oppure 
selezionandola, aprendo il menù contestuale con pulsante destro del mouse e scegliendo Properties). Nella 
sezione PCB settings, tra le altre cose è possibile forzare anche lo strato dove si troverà la pista, 
rimuovendo la spunta presente alla voce Unspecified routing layers e poi anche agli strati non interessati. 
Trasferendo uno schematico su Ultiboard per realizzare la scheda (layout) PCB, al simbolo circuitale di 
ciascun componente viene sostituita le relativa impronta (footprint) per il circuito stampato, mantenendo 
anche i riferimenti dei collegamenti tra i dispositivi nella relativa netlist. Sarà poi compito del progettista 
sbrogliare il circuito sulla scheda. 
 
Al fine di consentire l'instradamento migliore, Ultiboard potrebbe effettuare uno swap tra i pin di uno stesso 
componente (ad esempio, scambiando tra loro i due ingressi di una porta AND), o effettuare uno swap tra le 
sezioni di un componente (ad esempio, utilizzando una diversa porta logica in un integrato QUAD AND). 
Multisim fornisce a Ultiboard tutte le informazioni necessarie per fare ciò. 
Allo stesso modo, Multisim tiene traccia dei nodi di alimentazione e di terra. Alcuni nomi di rete predefiniti 
sono globali per un intero disegno; le reti riservate globali sono: 0, GND, VCC, VDD, VEE, e VSS. Ogni volta 
che una rete globale a qualsiasi livello nella gerarchia o su qualsiasi pagina di un progetto è chiamata con 
uno di questi nomi riservati di rete, questo si unisce a tale rete. La rete 0 corrisponde alla terra analogica, ed 
è il riferimento per tutte le tensioni, durante la simulazione, mentre GND è una terra digitale (è frequente, ai 
fini del layout PCB, voler isolare queste due reti di terra). Se si desidera mantenere la rete analogica e quella 
digitale distinte durante il processo di layout PCB, prima di esportare lo schematico verso Ultiboard, bisogna 
assicurarsi che nella finestra di dialogo Options > Sheet Properties nella sezione PCB il checkbox 
Connect digital ground to analog ground non sia selezionato (figura 11a). 
 
In ultimo, sempre nella sezione PCB, nel riquadro Unit settings (figura 11a) è possibile impostare l’unità di 
misura per la progettazione, che di default è il mil, ma può essere convenientemente cambiata in mm. 
 
Componenti come VCC, VDD, ecc che utilizzano il simbolo a "T" o il GND che utilizza il simbolo del 
triangolo, possono essere rinominati come desiderato. Quando un filo è collegato a uno di tali componenti, il 
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suo nome di rete viene automaticamente cambiato nel nome del componente. Ad esempio, in figura 12a il 
simbolo VCC = 5V è stato rinominato in "power" facendo doppio clic sul componente e cambiando il RefDes 
nella relativa finestra di dialogo. Il netname verrà automaticamente cambiato in "power" in modo che 
corrisponda al nuovo RefDes. 
Si può quindi scegliere di nominare alcune reti in modo da distinguerle durante lo sbroglio, agendo nella 
relativa finestra di dialogo delle proprietà Net Settings (figura 11b), che come già scritto, è raggiungibile 
cliccando due volte su ciascuna di esse nello schematico. Nella sezione Net name è possibile sostituire al 
nome di default dato da Multisim in maniera automatica e progressiva (in genere un numero) quello voluto 
da noi. Ad esempio in figura 11b si è rinominata la traccia 2, con Vo, trattandosi del segnale di uscita. Allo 
stesso modo si è proceduto con il segnale Vi. Inoltre, dato che la rete 0 corrisponde alla terra analogica, si è 
lasciato nello schematico un riferimento di terra in modo che Multisim (e poi Ultiboard) la indichi con tale 
nome. 
 

 
a) 

 
b) 

Figura 12 – Alimentazione rappresentata con il simbolo a "T" (a), alimentatore con regolatore LM7805 (b). 
 
Si vuole trasferire in Ultiboard lo schematico di figura 12b che rappresenta un alimentatore con LM7805, 
realizzato in ambiente Multisim.  
Prima di procedere al trasferimento di uno schematico in Ultiboard è comunque necessario accertarsi che i 
componenti utilizzati siano “reali”. In effetti, tutti i componenti simulati in Multisim sono virtuali. Essi sono 
rappresentazioni virtuali di dispositivi come diodi, transistor, resistori, ecc: collegati insieme e avviata la 
simulazione in Multisim, è possibile studiare come un certo circuito funzionerà nella realtà. Tuttavia dopo 
avere concluso un processo di progettazione e sperimentazione e aver effettuato i giusti dimensionamenti, è 
necessario sostituire i componenti virtuali con i relativi reali (ad esempio scegliere se si userà un integrato 
del tipo dual in line piuttosto che a montaggio superficiale) a ciascuno dei quali corrisponde uno specifico 
package con uno specifico footprint. Inoltre spesso durante la simulazione in Multisim vengono utilizzati 
componenti passivi virtuali, più comodi perché ideali, ma privi di footprint e che vanno quindi aggiornati con 
la relativa impronta. 
È comodo a tal fine selezionare l’opzione Reports > Bill Of Materials che apre una carta dei materiali 
(figura 13a) dove vengono elencati tutti i componenti utilizzati nel progetto, necessari alla produzione del 
circuito, con alcune importanti informazioni come: 
• quantità,  
• descrizione, con informazioni sul tipo di dispositivo (per esempio: resistenza) e il suo valore (per 

esempio: 1 kOhm) e alla sua tolleranza,  
• nome di riferimento sullo schematico (RefDes),  
• package o footprint del dispositivo. 
Mediante la carta dei materiali è quindi possibile, usando l’apposito pulsante Vir, visualizzare l’elenco dei 
dispositivi virtuali presenti sullo schematico e in tal caso procedere associandogli un footprint. Per fare ciò, 
bisogna tornare allo schematico e fare doppio clic sul componente in oggetto: si aprirà la relativa finestra di 
dialogo (figura 13b), quindi portarsi nella sezione Value e alla voce Layout Settings selezionare Edit 
Footprint. Nella successiva finestra che si aprirà, selezionare Select From Database e cercare l’impronta 
adatta al dispositivo in oggetto (è possibile usufruire anche di database aziendali, Corporate Database, o 
personali, User Database, caricati sotto Multisim). Si continuerà questo procedimento fino a che non si avrà 
associato a ogni dispositivo virtuale presente sullo schematico il relativo footprint. 
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a) 

 

b) 
Figura 13 – (a) Bill Of Materials, (b) proprietà di un dispositivo circuitale 
 
Per quanto riguarda invece i collegamenti di alimentazione, massa, tensione di ingresso o di uscita 
dell’intero PCB, è preferibile utilizzare connettori del tipo header strip (con sigla HDR) come raffigurato nello 
schematico di figura 12b. Nel caso in cui l’impronta di questi o di altri dispositivi non fosse presente nel 
Master Database di Multisim o in un proprio database (Personal o Corporate), si può decidere, 
momentaneamente, di non associargli un footprint, lasciandoli virtuali o non connessi, e una volta effettuato 
il trasferimento del circuito da Multisim ad Ultiboard, trovare una soluzione all’interno del database di 
quest’ultimo. In tal caso (come spiegato al punto 2.1) si procederà con l’immissione del componente 
direttamente dall’archivio di Ultiboard, scegliendo Place > From Database. Successivamente sarà 
necessario aprire la netlist, mediante Tool > Netlist Editor, per aggiornare le reti e i collegamenti mancanti 
al nuovo componente appena inserito. 
  
3.1 Trasferire uno schematico di Multisim in Ultiboard 
 
Dopo avere realizzato uno schematico in ambiente Multisim 11, per trasferirlo in Ultiboard, è necessario 
scegliere l’opzione Transfer > Transfer to Ultiboard > Transfer to Ultiboard 11 che in automatico chiede 
di salvare il circuito elettronico in un file di tipo netlist (con estensione *.ewnet) e subito dopo lo apre 
all’interno di Ultiboard 11. 
Si apre quindi una finestra Import Netlist (figura 14) che riporta la netlist importata da Multisim, e una volta 
aver dato l’OK, viene caricato il foglio di lavoro di Ultiboard con i componenti posti sul bordo della basetta. 
 

 
b) 

Figura 14 –Default Track Width and Clearance (a), Netlist importata (b). 
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Nel caso invece, che nel passaggio da Multisim ad Ultiboard siano rimasti dei componenti virtuali, privi di 
footprint, questi non verranno rappresentati sul piano di lavoro e si aprirà una ulteriore popup di avviso. In tal 
caso, (come spiegato al punto 2.2), sarà opportuno accedere al database e inserire i componenti mancanti 
usando l’archivio di Ultiboard o un eventuale archivio personale, scegliendo Place > From Database e 
successivamente sarà necessario aprire la netlist, mediante Tool > Netlist Editor, per aggiornare le reti e i 
collegamenti mancanti. 
 
Prima di effettuare lo sbroglio circuitale, è sempre utile fare un controllo alla netlist, utilizzando l’editor 
raggiungibile mediante Tool > Netlist Editor, per verificare che tutto sia a posto e che non ci siano ulteriori 
collegamenti tra le reti rimasti aperti (come spiegato al punto 2.4). 
 
Al momento dell’importazione dello schematico da Multisim vengono impostati in Ultiboard valori di default 
(in genere minimi) per vari elementi circuitali (traces, clearance, vias, pads) adatti ad agevolare l’autorouting 
nella rapida riuscita dello sbroglio circuitale automatico. Tali valori sono verificabili e modificabili all’interno 
delle varie schede dello Spreadsheet View, oppure all’interno delle varie sezioni della finestra Net Edit che 
permette di lavorare con la netlist (comando: Tool > Netlist Editor). Allo stesso modo, è possibile modificare 
le caratteristiche degli elementi presenti sullo schema, selezionandoli direttamente o in gruppo con doppio 
click del pulsante sinistro del mouse o aprendo il menu contestuale con il pulsante destro e scegliendo 
Properties (questa voce risulta evidenziata solo se tutti gli elementi selezionati sono dello stesso tipo). 
Nella scheda Nets dello Spreadsheet View sono riportate le impostazioni per le piste, ciascuna delle quali 
ha una Trace width di default pari a 10 mils (stessa informazione è reperibile per ogni Net nella sezione 
Width della finestra Net Edit alla voce Default trace width), mentre alla voce Trace clearance è riportata la 
minima distanza ammessa tra le piste, di default pari a 10 mils (stessa informazione si trova nella finestra 
Net Edit). 
 
Nella scheda Nets dello Spreadsheet View sono riportate le impostazioni per le piste, le quali hanno una 
Trace width di default pari a 10 mils. Stessa informazione è reperibile per ogni Net nella sezione Width 
della finestra Net Edit alla voce Default trace width, mentre alla voce Trace clearance è riportata la 
minima distanza ammessa tra le piste, di default pari a 10 mils. Questi valori possono essere modificati, ma 
è bene considerare che per sfruttare al meglio l’autorouting di Ultiboard è preferibile non inserire valori 
troppo alti in trace width (consigliabile 10÷30 mils) e in trace clearance (consigliabile 10÷20 mils), altrimenti 
l’algoritmo di autorouting potrebbe non essere in grado di ultimare lo sbroglio circuitale. Sarà sempre 
possibile in un secondo momento, a sbroglio completato in maniera automatica, intervenire ispessendo le 
piste o richiedendo una maggiore distanza tra il rame, riproponendo poi lo sbroglio automatico o procedendo 
in maniera manuale. 
 
Inoltre è bene prima dello sbroglio controllare e modificare le caratteristiche delle piazzole di tutti i 
componenti, che potrebbero avere dimensioni di default non adeguate alle specifiche desiderate. Si procede 
dunque abilitando il pulsante Enable Selecting Pads (oppure attraverso il menu Edit > Selection Filter > 
Enable Selecting Pads) selezionando tutte le piazzole che si vogliono modificare, quindi con doppio click 
del pulsante sinistro del mouse su una selezione (o con click singolo del pulsante destro, scegliendo 
Properties nel relativo menu contestuale) si accede alla finestra Through Hole Pin Properties e ci si porta 
nella sezione Pad (come spiegato al punto 2.5). 
 
A questo punto, se si dispone di una versione di Ultiboard che contiene il tool di autoplacement, può essere 
comodo utilizzarlo, selezionando Autoroute > Start Autoplacement, per lasciare al software la collocazione 
ottimale dei componenti sulla basetta (come spiegato al punto 2.5). Altrimenti si procederà allo spostamento 
dei componenti in maniera manuale, abilitando il pulsante Enable Selecting Parts e selezionando tutti o 
uno per volta i componenti da sistemare sulla basetta. 
Il successivo inserimento delle piste può essere fatto utilizzando uno dei metodi spiegato al punto 2.5, in 
modalità manuale oppure automatica. Una volta disegnato il circuito stampato, si potrà passare alla 
realizzazione del PCB, stampandolo mediante File > Print (come spiegato al punto 2.6). 
 
Se in fase di realizzazione o ad ultimazione lavoro si vogliono variare le dimensioni (Board Size) della 
basetta (un’area più grande agevola l’autoroute, ma è anche opportuno realizzare PCB di dimensioni 
contenute), si può procedere abilitando Edit > Selection Filter > Enable Selecting other objects, oppure 

selezionando l’icona , quindi cliccando con il pulsante destro del mouse sul contorno della basetta, come 
riportato in figura 15a (oppure usando CTRL+A e verificando che non vengano selezionati oltre al contorno, 
anche altri oggetti sul PCB, come ponticelli, eccetera… ). Il contorno della basetta verrà evidenziato e sarà 
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possibile variare le sue dimensioni agendo sui quadratini posti al centro di ogni lato, selezionandoli con il 
mouse e trascinandoli. 
 

 A questo punto potrebbe essere necessario riposizionare il Reference point, il quale è un punto di 
riferimento del layout PCB, dal momento che tutte le misure sono mostrate relativamente a questo punto di 
origine. La procedura per impostare il punto di riferimento è la seguente: scegliere Design > Set Reference 
point. Il puntatore del mouse cambia disegno, assumendo le sembianze di un reference point; quindi 
portarsi nel nuovo punto di riferimento e fare clic per posizionare il punto di riferimento. Nell'esempio 
riportato di seguito in figura 15b il punto di riferimento è stato collocato nell'angolo inferiore sinistro della 
tavola PCB. 
 

 
a) 

 
 
 

 
 
 

b) 

Figura 15 – (a) Variare il Board Size e (b) settare il Reference point 
 
 
3.2 Backward annotation di Ultiboard  
 
L’integrazione tra Ultiboard e Multisim assicura un facile trasferimento di informazioni nelle varie fasi di 
messa a punto del progetto, grazie anche alla backannotation6 (annotazione all’indietro), un processo 
altamente automatizzato che assicura che le modifiche apportate a una progettazione Ultiboard siano 
trasferite nello schematico di origine di Multisim. Questo processo aiuta a mantenere schematico e layout del 
PCB coerenti l'uno con l'altro.  
Il processo di backward annotation avviene in Ultiboard selezionando Transfer > Back annotate to 
Multisim > Back annotate to Multisim 11, che apre una finestra di dialogo Save As per salvare il file nel 
formato *.ewnet (volendo è possibile sovrascrivere il file creato da Multisim durante il processo di forward 
annotation, quando si è trasferito lo schematico di origine di Multisim verso Ultiboard). In automatico Multisim 
cerca il file da associare a quello appena salvato con gli aggiornamenti CAD e se non è già aperto, chiede di 
cercarlo. Una volta aperto il corrispondente file di disegno di Multisim (nel formato *.ms11), appare una 
finestra di dialogo Backward Annotation che mostra i cambiamenti annotati, i quali vengono confermati una 
volta cliccato su OK e riportati nello schematico di Multisim.. All’interno di questa finestra è comunque 
possibile scegliere quei cambiamenti a cui dare corso e quelli da evitare o da modificare ulteriormente.  
 
Allo stesso modo è possibile procedere con Multisim leggendo il file in formato *.ewnet in un momento 
successivo o aprendo (valido per le precedenti versioni di Ultiboard e Multisim) il file di registro in cui 
Ultiboard salva tutte le modifiche apportate a un PCB, il quale ha lo stesso nome del progetto, ma 
estensione *.log. Non tutte le modifiche che vengono apportate al PCB possono comunque essere annotate 
all’indietro per Multisim, ma solo le seguenti: 
• rimozione di un componente, 
• ridenominazione di un componente,  
• ridenominazione della netlist.  
I cambiamenti effettuati in Ultiboard saranno riportati nello schematico di Multisim.  
In tal caso, per effettuare una back annotate, salvare e chiudere il disegno di Ultiboard. Aprire in Multisim il 
file con lo schematico su cui si intende riportare la variazione, selezionare Transfer > Back Annotate from 
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6 La backannotation è una caratteristica importante del software CAD. Un componente rinominato o eliminato può 
provocare incongruenze tra lo schematico e la progettazione del PCB. La backannotation permette di superare queste 
incongruenze, tenendo traccia delle modifiche. 

 
 



Ultiboard. Un finestra di dialogo Open permette di selezionare il file *.log desiderato, per aprirlo. 
Successivamente si aprirà la finestra di dialogo Annotation Log (figura 16), che permetterà di selezionare i 
cambiamenti che si vuole annotare all’indietro nello schematico. Dato l’OK, verranno apportati nello 
schematico i cambiamenti richiesti.  
 

 
Figura 16 – Una finestra di dialogo Annotation Log 
 
Allo stesso modo, le successive modifiche di schema in Multisim potranno essere annotate in avanti verso 
Ultiboard, in modo che i progressi di progettazione PCB compiuti fino al momento non siano persi, se viene 
apportata una piccola variazione nello schematico. In tal caso selezionare Transfer > Forward Annotate to 
Ultiboard 11. Salvare il file con il nome desiderato e aprirlo in Ultiboard, usandolo come aggiornamento di 
un circuito già disegnato.  
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